use strict;
my $str = 'फ्रांस';
my $regex = qr/[^\p{L}\p{M}\d_]/up;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";