$re = '/[^\p{L}\p{M}\d_]/u';
$str = 'फ्रांस';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;