#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\(([^()]*)\)(?=(?:[^()]*\)){3})"
Local $sString = "(aaa) (ee (ff (gg))) (bbb (ccc)) ddd"
Local $sSubst = "{$1}"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)