const regex = /\(([^()]*)\)(?=(?:[^()]*\)){3})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\(([^()]*)\\)(?=(?:[^()]*\\)){3})', 'gm')
const str = `(aaa) (ee (ff (gg))) (bbb (ccc)) ddd`;
const subst = `{$1}`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);