use strict;
my $str = '(aaa) (ee (ff (gg))) (bbb (ccc)) ddd';
my $regex = qr/\(([^()]*)\)(?=(?:[^()]*\)){3})/mp;
my $subst = '{$1}';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";