package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<<act ("([^"\\]|\\.)*")`)
var str = `<<act "want" "don't want">><</act>>
<<act "\"want\"" "don't want">><</act>>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}