re = /<<act ("([^"\\]|\\.)*")/m
str = '<<act "want" "don\'t want">><</act>>
<<act "\\"want\\"" "don\'t want">><</act>>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end