$re = '/<<act ("([^"\\\\]|\\\\.)*")/m';
$str = '<<act "want" "don\'t want">><</act>>
<<act "\\"want\\"" "don\'t want">><</act>>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);