using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\?{3})\d+|\d+(?=\?{3})";
string input = @"acc5???7???7ss?3rr1??5
5???abc???3
5????abc2???xyz????1abc???3abc";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}