re = /(?<=\?{3})\d+|\d+(?=\?{3})/m
str = 'acc5???7???7ss?3rr1??5
5???abc???3
5????abc2???xyz????1abc???3abc'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end