#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=[^\?]\?{3})\d+|\d+(?=\?{3}(?:[^\?]|$))"
Local $sString = "acc5???7???7ss?3rr1??5" & @CRLF & _
"5???abc???3" & @CRLF & _
"???1x5????abc2???xyz????1abc???3abc" & @CRLF & _
"???1x5abc10???" & @CRLF & _
"????1x5abc10????"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")