$re = '/(?<=[^\?]\?{3})\d+|\d+(?=\?{3}(?:[^\?]|$))/m';
$str = 'acc5???7???7ss?3rr1??5
5???abc???3
???1x5????abc2???xyz????1abc???3abc
???1x5abc10???
????1x5abc10????';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);