use strict;
my $str = 'acc5???7???7ss?3rr1??5
5???abc???3
???1x5????abc2???xyz????1abc???3abc
???1x5abc10???
????1x5abc10????';
my $regex = qr/(?<=[^\?]\?{3})\d+|\d+(?=\?{3}(?:[^\?]|$))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}