# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=[❶❷❸❹❺❻❼❽❾❿➀].*)[❶❷❸❹❺❻❼❽❾❿➀]//gm;t' <<< "❶Hi dear how❽ are❺❼ ❽❽you❼
Hi ❶ dear how❽ are❺❼ ❽❽you❼"