const regex = /(?<=[❶❷❸❹❺❻❼❽❾❿➀].*)[❶❷❸❹❺❻❼❽❾❿➀]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=[❶❷❸❹❺❻❼❽❾❿➀].*)[❶❷❸❹❺❻❼❽❾❿➀]', 'gm')
const str = `❶Hi dear how❽ are❺❼ ❽❽you❼
Hi ❶ dear how❽ are❺❼ ❽❽you❼`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);