#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)server_name\h*(.*);"
Local $sString = "# This file was autogenerated by Puppet [ wordpress::vhost ]" & @CRLF & _
"# Any manual edit to this file will be automatically removed" & @CRLF & _
"# ©2016, DevOps team" & @CRLF & _
"" & @CRLF & _
"server {" & @CRLF & _
" listen 443 ssl;" & @CRLF & _
"" & @CRLF & _
" root /var/www/as888;" & @CRLF & _
" index index.php;" & @CRLF & _
"" & @CRLF & _
" server_name wptraining-sdemo.mysysweb.com;" & @CRLF & _
" ......" & @CRLF & _
" ......" & @CRLF & _
"# This file was autogenerated by Puppet [ wordpress::vhost ]" & @CRLF & _
"# Any manual edit to this file will be automatically removed" & @CRLF & _
"# ©2016, DevOps team" & @CRLF & _
"" & @CRLF & _
"server {" & @CRLF & _
" listen 443 ssl;" & @CRLF & _
"" & @CRLF & _
" root /var/www/as888;" & @CRLF & _
" index index.php;" & @CRLF & _
"" & @CRLF & _
" server_name wptraining-sdemo.mysysweb.com;" & @CRLF & _
" ......" & @CRLF & _
" ......"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")