import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "server_name\\h*(.*);";
final String string = "# This file was autogenerated by Puppet [ wordpress::vhost ]\n"
+ "# Any manual edit to this file will be automatically removed\n"
+ "# ©2016, DevOps team\n\n"
+ "server {\n"
+ " listen 443 ssl;\n\n"
+ " root /var/www/as888;\n"
+ " index index.php;\n\n"
+ " server_name wptraining-sdemo.mysysweb.com;\n"
+ " ......\n"
+ " ......\n"
+ "# This file was autogenerated by Puppet [ wordpress::vhost ]\n"
+ "# Any manual edit to this file will be automatically removed\n"
+ "# ©2016, DevOps team\n\n"
+ "server {\n"
+ " listen 443 ssl;\n\n"
+ " root /var/www/as888;\n"
+ " index index.php;\n\n"
+ " server_name wptraining-sdemo.mysysweb.com;\n"
+ " ......\n"
+ " ......";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}