# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"server_name\h*(.*);"
test_str = ("# This file was autogenerated by Puppet [ wordpress::vhost ]\n"
"# Any manual edit to this file will be automatically removed\n"
"# ©2016, DevOps team\n\n"
"server {\n"
" listen 443 ssl;\n\n"
" root /var/www/as888;\n"
" index index.php;\n\n"
" server_name wptraining-sdemo.mysysweb.com;\n"
" ......\n"
" ......\n"
"# This file was autogenerated by Puppet [ wordpress::vhost ]\n"
"# Any manual edit to this file will be automatically removed\n"
"# ©2016, DevOps team\n\n"
"server {\n"
" listen 443 ssl;\n\n"
" root /var/www/as888;\n"
" index index.php;\n\n"
" server_name wptraining-sdemo.mysysweb.com;\n"
" ......\n"
" ......")
matches = re.search(regex, test_str, re.MULTILINE)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.