using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<\/script>[\s\S]*?<\/script>)";
string substitution = @"";
string input = @"<h2>Misrepresentation of the Facts</h2>
</script>
<!-- Articles - Leaderboard 728x90 -->
</iframe></ins></ins></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
<h2>Who Can Commit the Crime</h2>
</script>
<!-- Articles - Leaderboard 728x90 -->
</iframe></ins></ins></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}