import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<\\/script>[\\s\\S]*?<\\/script>)";
final String string = "<h2>Misrepresentation of the Facts</h2>\n"
+ "</script>\n"
+ "<!-- Articles - Leaderboard 728x90 -->\n"
+ "</iframe></ins></ins></ins>\n"
+ "<script>\n"
+ "(adsbygoogle = window.adsbygoogle || []).push({});\n"
+ "</script>\n"
+ "<h2>Who Can Commit the Crime</h2>\n\n"
+ "</script>\n"
+ "<!-- Articles - Leaderboard 728x90 -->\n"
+ "</iframe></ins></ins></ins>\n"
+ "<script>\n"
+ "(adsbygoogle = window.adsbygoogle || []).push({});\n"
+ "</script>";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}