import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!:)//[^\\r\\n]*";
final String string = "LOAD TEXT(VKONT) AS ΣΥΜΒΟΛΑΙΟ //amatak 2022/07/27 add where\n\n"
+ "FROM [lib://DataLakeQVDs_V2 (intranet_qview)/ΠΑΡΑΓΩΓΙΚΟΤΗΤΑ/PROD_EX_FKK_INSTPLN_HEAD.QVD]\n\n"
+ "(qvd) where match(left(VKONT,1),3); //amatak 2022/07/27 add where";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}