use strict;
my $str = 'LOAD TEXT(VKONT) AS ΣΥΜΒΟΛΑΙΟ //amatak 2022/07/27 add where
FROM [lib://DataLakeQVDs_V2 (intranet_qview)/ΠΑΡΑΓΩΓΙΚΟΤΗΤΑ/PROD_EX_FKK_INSTPLN_HEAD.QVD]
(qvd) where match(left(VKONT,1),3); //amatak 2022/07/27 add where';
my $regex = qr%(?<!:)//[^\r\n]*%mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}