const regex = /^(?!.*margins.*).*smarg.*$
/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!.*margins.*).*smarg.*$
', 'gmi')
const str = ` mainLayout.setContentsMargins(6, 6, 6, 6)
def save(self, smArgs):
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}