$re = '/^(?!.*margins.*).*smarg.*$
/mi';
$str = ' mainLayout.setContentsMargins(6, 6, 6, 6)
def save(self, smArgs):
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);