re = /^(?!.*margins.*).*smarg.*$
/mi
str = ' mainLayout.setContentsMargins(6, 6, 6, 6)
def save(self, smArgs):
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end