#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?miU)([\s\S]+)((from:(?:(?!from:)[\s\S])+?sent:(?:(?!sent:)[\s\S])+?to:(?:(?!to:)[\s\S])+?subject:(?:(?!subject:)[\s\S])+))"
Local $sString = "Hello World from: the other side of the first email" & @CRLF & _
"" & @CRLF & _
"from: this" & @CRLF & _
"sent: at" & @CRLF & _
"to: that" & @CRLF & _
"subject: what" & @CRLF & _
"" & @CRLF & _
"second email" & @CRLF & _
"" & @CRLF & _
"from: this" & @CRLF & _
"sent: at" & @CRLF & _
"to: that" & @CRLF & _
"subject: what" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"third email" & @CRLF & _
"" & @CRLF & _
"from: this" & @CRLF & _
"date: at" & @CRLF & _
"to: that" & @CRLF & _
"subject: what" & @CRLF & _
"" & @CRLF & _
"fourth email"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")