const regex = /([\s\S]+)((from:(?:(?!from:)[\s\S])+?sent:(?:(?!sent:)[\s\S])+?to:(?:(?!to:)[\s\S])+?subject:(?:(?!subject:)[\s\S])+))/mi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([\\s\\S]+)((from:(?:(?!from:)[\\s\\S])+?sent:(?:(?!sent:)[\\s\\S])+?to:(?:(?!to:)[\\s\\S])+?subject:(?:(?!subject:)[\\s\\S])+))', 'mi')
const str = `Hello World from: the other side of the first email
from: this
sent: at
to: that
subject: what
second email
from: this
sent: at
to: that
subject: what
third email
from: this
date: at
to: that
subject: what
fourth email`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}