import re
regex = re.compile(r"([\s\S]+)((from:(?:(?!from:)[\s\S])+?sent:(?:(?!sent:)[\s\S])+?to:(?:(?!to:)[\s\S])+?subject:(?:(?!subject:)[\s\S])+))", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("Hello World from: the other side of the first email\n\n"
"from: this\n"
"sent: at\n"
"to: that\n"
"subject: what\n\n"
"second email\n\n"
"from: this\n"
"sent: at\n"
"to: that\n"
"subject: what\n\n\n"
"third email\n\n"
"from: this\n"
"date: at\n"
"to: that\n"
"subject: what\n\n"
"fourth email")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")