const regex = new RegExp('\\r?\\n(?!\\s)', 'gm')
const str = `\\r?\\n(?!\\s)
Primer ejemplo:
Esta esta linea no se une a la anterior
Segundo ejemplo:
Esta linea se une a la anterior
Primer ejemplo:
Esta esta linea no se une a la anterior
Segundo ejemplo: Esta linea se une a la anterior`;
const subst = ` `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);