$re = '/\r?\n(?!\s)/m';
$str = '\\r?\\n(?!\\s)
Primer ejemplo:
Esta esta linea no se une a la anterior
Segundo ejemplo:
Esta linea se une a la anterior
Primer ejemplo:
Esta esta linea no se une a la anterior
Segundo ejemplo: Esta linea se une a la anterior';
$subst = " ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;