using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b([1-9]|[1-9][0-9]|100)\b";
string input = @"1 1 1 21 23 1 99 100 101 201 999 01 007";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}