// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\b([1-9]|[1-9][0-9]|100)\b").unwrap();
let string = "1 1 1 21 23 1 99 100 101 201 999 01 007";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}