import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<!--\\s*(\\S+)\\s*-->((?:\\n|.)*)<!--\\s*###\\1\\s*-->";
final String string = "<!-- DETAILS-->\n\n"
+ " <li><span>xxxx</span></li>\n"
+ " <li><span>xxxx</span></li>\n"
+ " <li><span>xxxx</span></li>\n"
+ " <li><span>xxxx/span></li>\n"
+ " <li><span>xxxx</span></li>\n"
+ " <li><span>xxxx</span></li>\n"
+ " <li><span>xxxx</span></li>\n\n"
+ " <!-- ###DETAILS -->";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}