$re = '/<!--\s*(\S+)\s*-->((?:\n|.)*)<!--\s*###\1\s*-->/';
$str = '<!-- DETAILS-->
<li><span>xxxx</span></li>
<li><span>xxxx</span></li>
<li><span>xxxx</span></li>
<li><span>xxxx/span></li>
<li><span>xxxx</span></li>
<li><span>xxxx</span></li>
<li><span>xxxx</span></li>
<!-- ###DETAILS -->';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);