re = /<!--\s*(\S+)\s*-->((?:\n|.)*)<!--\s*###\1\s*-->/
str = '<!-- DETAILS-->
<li><span>xxxx</span></li>
<li><span>xxxx</span></li>
<li><span>xxxx</span></li>
<li><span>xxxx/span></li>
<li><span>xxxx</span></li>
<li><span>xxxx</span></li>
<li><span>xxxx</span></li>
<!-- ###DETAILS -->'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end