const regex = new RegExp('^[\\\\\\/]?|(?<![\\\\\\/])[\\\\\\/]?$', 'mg')
const str = `
path
/path
\\path
path/
path\\
/path/
\\path\\`;
const subst = `/`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);