re = /^[\\\/]?|(?<![\\\/])[\\\/]?$/m
str = '
path
/path
\\path
path/
path\\
/path/
\\path\\'
subst = '/'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result