$re = '`^[\\\\\/]?|(?<![\\\\\/])[\\\\\/]?$`m';
$str = '
path
/path
\\path
path/
path\\
/path/
\\path\\';
$subst = "/";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;