#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b[A-Z]{2}[0-9]{2}(?:[ ]?[0-9]{4}){4}(?!(?:[ ]?[0-9]){3})(?:[ ]?[0-9]{1,2})?\b"
Local $sString = "AB12 1234 1234 1234 1234" & @CRLF & _
"AB12 1234 1234 1234 1234 1" & @CRLF & _
"AB12 1234 1234 1234 1234 12" & @CRLF & _
"" & @CRLF & _
"AB123456789012345678" & @CRLF & _
"AB1234567890123456789" & @CRLF & _
"AB12345678901234567890" & @CRLF & _
"" & @CRLF & _
"Not allowed" & @CRLF & _
"------------" & @CRLF & _
"AB12 1234 1234 1234 123 (to few numbers)" & @CRLF & _
"AB12 1234 1234 1234 1234 123 (to many numbers) " & @CRLF & _
"1234 1234 1234 1234 1234 (starts with numbers)" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")