using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b[A-Z]{2}[0-9]{2}(?:[ ]?[0-9]{4}){4}(?!(?:[ ]?[0-9]){3})(?:[ ]?[0-9]{1,2})?\b";
string input = @"AB12 1234 1234 1234 1234
AB12 1234 1234 1234 1234 1
AB12 1234 1234 1234 1234 12
AB123456789012345678
AB1234567890123456789
AB12345678901234567890
Not allowed
------------
AB12 1234 1234 1234 123 (to few numbers)
AB12 1234 1234 1234 1234 123 (to many numbers)
1234 1234 1234 1234 1234 (starts with numbers)
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}