re = /\b[A-Z]{2}[0-9]{2}(?:[ ]?[0-9]{4}){4}(?!(?:[ ]?[0-9]){3})(?:[ ]?[0-9]{1,2})?\b/m
str = 'AB12 1234 1234 1234 1234
AB12 1234 1234 1234 1234 1
AB12 1234 1234 1234 1234 12
AB123456789012345678
AB1234567890123456789
AB12345678901234567890
Not allowed
------------
AB12 1234 1234 1234 123 (to few numbers)
AB12 1234 1234 1234 1234 123 (to many numbers)
1234 1234 1234 1234 1234 (starts with numbers)
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end