const regex = /(?m)(?:https?:\/\/)?(?:www\.)?((?:[a-zA-Z\x{00a1}-\x{ffff}0-9.\-])+(?:\.[a-zA-Z]{2,63}))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?m)(?:https?:\\\/\\\/)?(?:www\\.)?((?:[a-zA-Z\\x{00a1}-\\x{ffff}0-9.\\-])+(?:\\.[a-zA-Z]{2,63}))', 'g')
const str = `https://www.autoitscript.com.tr/
www.autoitscript.de
http://www.autoitscript.co.uk
http://autoitscript.tr
autoit-script.fr`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}