// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:https?:\/\/)?(?:www\.)?((?:[a-zA-Z\x{00a1}-\x{ffff}0-9.\-])+(?:\.[a-zA-Z]{2,63}))").unwrap();
let string = "https://www.autoitscript.com.tr/
www.autoitscript.de
http://www.autoitscript.co.uk
http://autoitscript.tr
autoit-script.fr";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}