package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)cow\n([\s\S]*?)\nmilk`)
var str = `Their
cow
gives
more
milk
His
cow
gives
less
milk`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}