$re = '/cow\n([\s\S]*?)\nmilk/m';
$str = 'Their
cow
gives
more
milk
His
cow
gives
less
milk';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);