using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^.]*\bbad\b[^.]*|(\bgood\b)";
string input = @"A good example of a bad regex.
A bad example of a good regex.
A bad example. A good regex.
A good example. A bad regex.
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}