// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)[^.]*\bbad\b[^.]*|(\bgood\b)").unwrap();
let string = "A good example of a bad regex.
A bad example of a good regex.
A bad example. A good regex.
A good example. A bad regex.
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}