import re
regex = re.compile(r"[^.]*\bbad\b[^.]*|(\bgood\b)", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("A good example of a bad regex.\n"
"A bad example of a good regex.\n"
"A bad example. A good regex.\n"
"A good example. A bad regex.\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")