using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"0|1|-(\g<0>)(\g<0>)";
string input = @"--01-0-01";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}