#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\\((0_ASW|10_BSW)\\)([A-Za-z0-9]+)"
Local $sString = "C:\MyPath\0_ASW\Mod2000" & @CRLF & _
"C:\MyPath\0_ASW\Mod2005\SubDir" & @CRLF & _
"C:\MyPath\10_BSW\ModA\SubDir" & @CRLF & _
"C:\MyPath\10_BSW\ModB" & @CRLF & _
"C:\MyPath\10_BSW\ModC\" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")